GoDaddy 도움말

워드프레스 플러그인 오류 수정하기

워드프레스에서 플러그인 오류를 수정하려면 해당 단계를 수행합니다.

문제 해결을 위해 워드프레스 사이트 준비하기:

  1. 문제를 해결하기 전에 항상 사이트를 백업해야 합니다.
  2. 모든 워드프레스 플러그인, 특히 캐싱 플러그인을 비활성화합니다.
  3. 사이트가 이 플러그인을 사용하는 경우 WP_CACHE를 비활성화합니다.

PHP 관련 워드프레스 오류 이해하기

이전 문제 해결로 PHP 오류가 드러난 경우 다음 표를 참조하여 오류 파악에 도움을 받을 수 있습니다.


오류 유형정의 및 다음 단계
E_ERROR스크립트 종료를 유발하는 심각한 오류입니다. 이는 일반적으로 클래스나 함수처럼 존재하지 않는 객체를 호출하여 발생합니다. 이는 버전 비호환 문제로 인해 종종 발생할 수 있습니다. 워드프레스 버전, 테마 및 플러그인을 업데이트해야 합니다.
E_WARNING이 오류는 스크립트 종료를 유발하지 않는 런타임 경고입니다. 이는 발생하지만 PHP의 처리를 중단하지는 않는 잠재적인 문제입니다. 이러한 경고에는 사용 중인 코드가 오래된 PHP 버전을 사용하고 있으므로 업데이트해야 함을 나타내는 사용 중단 경고가 포함될 수 있습니다. PHP 로그의 경고는 사용자가 경험하고 있는 문제와 반드시 관련되지는 않을 수 있습니다.
E_PARSE컴파일 시간 구문 분석 오류입니다. 이 오류는 일반적으로 누락 세미콜론 ;, 괄호 (), 여는 괄호나 닫는 괄호 {} 또는 많은 기타 구문 오류와 같은 PHP 구문 오류를 나타냅니다. 오류 메시지에 지정된 파일 및 줄을 검토하고 잠재적인 구문 오류를 찾아야 합니다.
E_NOTICE코드 오류로 인해 발생하는 런타임 공지입니다. 이러한 오류는 일반적으로 스크립트 종료를 유발하지 않는 PHP 오류입니다. 이러한 오류는 코드에 문제가 있을 수 있지만 스크립트의 기능은 정상일 수 있음을 나타냅니다. 한 가지 일반적인 원인은 정의되지 않은 PHP 변수를 사용하는 것입니다. PHP 로그의 공지는 사용자가 경험하고 있는 문제와 반드시 관련되는 것은 아닐 수 있습니다.

워드프레스 구성 요소 업데이트하기

워드프레스 버전, 테마 또는 플러그인을 업데이트할 때 다른 항목과 충돌을 유발할 수 있습니다. 모든 워드프레스 구성 요소를 업데이트하면 사이트를 정상으로 되돌릴 수 있습니다.

다음을 최신 버전으로 업데이트:

관련 단계

상세 정보