주 콘텐츠로 건너뛰기
연락처
  • 월-금 6:00am -11:00pm 월요일 부터 금요일 까지.080 880 2111
  • 월-금 6:00am -11:00pm 월요일 부터 금요일 까지.080 880 2111
전화 번호 및 시간
고객센터

온라인 도움말 리소스 살펴보기

도움말

관리형 워드프레스 도움말

귀하를 위해 최선을 다해 이 페이지를 번역했습니다. 영어 페이지도 이용할 수 있습니다.

이전 PHP 버전 사용 중지

경고 : 2022 년 7 월 동안 Managed WordPress 호스팅 플랫폼에서 PHP의 단종 (EOL) 버전이 사용 중지됩니다.

PHP는 워드 프레스 코드의 기반이되는 프로그래밍 언어입니다. 이 언어는 서버에서 실행되며 최신 상태로 유지하는 것은 WordPress 사이트의 보안 및 기능에 중요합니다.

답변을 보려면 질문을 선택하세요.

왜 이런 일이 발생합니까?

EOL (End of Life) 버전은 보안 업데이트에 대해 더 이상 지원되지 않으므로 WordPress 사이트가 취약해질 수 있습니다. 현재 PHP 버전으로 업데이트하면 대부분의 사이트에서 성능과 안정성이 향상 될 수 있습니다.

이를 준비하기 위해 다음 PHP 버전을 폐기 할 준비를하고 있습니다.

  • 5.6
  • 7.0, 7.1, 7.2, 7.3

사용중인 PHP 버전을 어떻게 알 수 있나요?

PHP 버전은 여러 위치에서 볼 수 있습니다.

  • Managed WordPress 호스팅 대시 보드 : 설정 에서 > 생산 현장 > PHP 버전 . 여기에서 PHP 버전을 업데이트 할 수도 있습니다.
  • 워드 프레스 대시 보드 : 홈페이지에 PHP 업데이트가 필요하다는 관리자 메시지가 표시됩니다. 링크를 따라 가면 PHP 버전을 업데이트 할 수 있습니다.
  • PHP 정보 스크립트 : PHP 정보 파일을 만들어 public_html 디렉터리에 배치 할 수 있습니다. 브라우저에 파일이로드 될 때 PHP 버전 정보가 표시됩니다.

나에게 무엇을 권장합니까?

사이트가 PHP의 EOL 버전에서 실행되고있는 경우 사전에 사이트를 업데이트하는 것이 좋습니다.

먼저 플러그인활성 테마 를 업데이트해야합니다. 이것은 워드 프레스 사이트의 PHP 버전을 업데이트 할 때 문제가 될 수있는 가장 큰 원인입니다. 이 기회에 플러그인 및 테마에 대한 개발자 설명서를 검토하여 PHP 버전을 업데이트 할 때 알아야 할 문제가 있는지 확인해야합니다.

당사의 디럭스, 최고급 및 전자 상거래 Managed WordPress 플랜에는 최신 버전의 PHP에서 사이트를 테스트 할 수있는 원 클릭 준비 사이트 가 포함되어 있습니다. 라이브 사이트에 영향을주지 않고 발생할 수있는 문제를 해결하고 극복 할 수있는 좋은 장소입니다. 업데이트를 완료하고 준비 사이트의 문제를 수정하면 변경 내용을 라이브 사이트에 푸시 할 수 있습니다.

참고 : 사이트가 기본 Managed WordPress 플랜 인 경우 준비 환경에 액세스하려면 디럭스, 최고급 또는 전자 상거래 플랜으로 업그레이드해야합니다. ( 업그레이드 방법은 다음과 같습니다. )

사이트가 실행중인 EOL PHP 버전에 따라 사이트가 제대로 작동하기 위해 변경할 사항이 많지 않을 수 있습니다. 이전 버전 일수록 변경 사항에 맞게 사이트를 준비하는 데 더 많은 작업이 필요할 수 있습니다.

사이트가 PHP 버전 5.6에서 실행중인 경우 PHP.net 에서 PHP 7.0.x에서 더 이상 사용되지 않는 기능을 검토해야합니다. PHP 버전 변경 후 사이트가 제대로 작동하는지 확인하기 위해 WordPress 개발자 또는 관리자의 도움이 필요할 수 있습니다.

사이트가 PHP 7.0-7.3에서 실행중인 경우 PHP.net의 부록에서 최신 버전으로의 마이그레이션에 대한 정보를 찾을 수 있습니다.

사이트를 지원할 워드 프레스 개발자 또는 관리자가없는 경우 유료 서비스 인 워드 프레스 프리미엄 지원 을 통해 도움을받을 수 있습니다.

PHP 버전은 어떻게 변경합니까?

Managed WordPress 호스팅 대시 보드의 설정 섹션 에서 PHP 버전을 변경할 수 있습니다.

아무것도하지 않으면 어떻게 되나요?

귀하의 웹 사이트가 현재 EOL PHP 버전을 사용 중이고 작동하지 않는 경우, 웹 사이트의 일부 측면이 이러한 이전 버전의 지원 중단 된 코드에 의존하는 경우 작동하지 않을 수 있습니다. 확실하지 않은 경우 웹 개발자 또는 WordPress 관리자에게 문의해야합니다.

EOL PHP 버전이 사용 중지됨에 따라 아직 EOL 버전을 사용중인 사용자는 사이트가보다 안정된 최신 버전의 PHP로 변경되었음을 알 수 있습니다.